<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","errorBeacon":"bam-cell.nr-data.net","licenseKey":"def25c5cff","applicationID":"282811705,282811706","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":258,"agent":""}</script>
<script>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</script>
<script src='https://cdn.rivals.com/production/assets/window_name-426a8929f8d33048988258b1fc9ba7fa371d790b3661496339ffb6f2b1141c3f.js'></script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='stage.guce.rivals.com' name='oath:guce:consent-host'>
<meta content='true' name='oath:guce:report-only'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-83298012-1', 'auto');
</script>

<script>
dataLayer = [];
</script>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PHNjcmlwdD4KICAoZnVuY3Rpb24odyxkLHMsbCxpKXsKICAgICAgICBpZiAo
d2luZG93Ll9kaWRBc3luY0luamVjdEdvb2dsZVRhZ01hbmFnZXIpIHJldHVy
bjsKICAgICAgICB3W2xdPXdbbF18fFtdO3dbbF0ucHVzaCh7J2d0bS5zdGFy
dCc6CiAgICAgICAgbmV3IERhdGUoKS5nZXRUaW1lKCksZXZlbnQ6J2d0bS5q
cyd9KTt2YXIgZj1kLmdldEVsZW1lbnRzQnlUYWdOYW1lKHMpWzBdLAogICAg
ICAgIGo9ZC5jcmVhdGVFbGVtZW50KHMpLGRsPWwhPSdkYXRhTGF5ZXInPycm
bD0nK2w6Jyc7ai5hc3luYz10cnVlO2ouc3JjPQogICAgICAgICdodHRwczov
L3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNvbS9ndG0uanM/aWQ9JytpK2RsKycm
Z3RtX2F1dGg9JysnS2hINmhlQ3BvV0pVSG5xVnpkRWE3dycrCiAgICAgICAg
JyZndG1fcHJldmlldz0nKydlbnYtMScrJyZndG1fY29va2llc193aW49eCc7
Zi5wYXJlbnROb2RlLmluc2VydEJlZm9yZShqLGYpOwogICAgICAgIHdpbmRv
dy5fZGlkQXN5bmNJbmplY3RHb29nbGVUYWdNYW5hZ2VyID0gdHJ1ZTsKICAg
ICAgfSkod2luZG93LGRvY3VtZW50LCdzY3JpcHQnLCdkYXRhTGF5ZXInLCdH
VE0tTUY2UFhYQycpOwo8L3NjcmlwdD4KPG5vc2NyaXB0Pgo8aWZyYW1lIGhl
aWdodD0nMCcgc3JjPSdodHRwczovL3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNv
bS9ucy5odG1sP2lkPUdUTS1NRjZQWFhDJmFtcDtndG1fYXV0aD1LaEg2aGVD
cG9XSlVIbnFWemRFYTd3JmFtcDtndG1fcHJldmlldz1lbnYtMSZhbXA7Z3Rt
X2Nvb2tpZXNfd2luPXgnIHN0eWxlPSdkaXNwbGF5Om5vbmU7dmlzaWJpbGl0
eTpoaWRkZW4nIHdpZHRoPScwJz48L2lmcmFtZT4KPC9ub3NjcmlwdD4KCgo=

</div>
</div>
<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-17665c085dfaf620c961e1c0ddea354a20565cd5002add288461398e9f21d1eb.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansCondFonts-74c0340099b3ec93e18951b2b059a74493c5db2e72ef7acd1cf1c42a6e4a523d.css' rel='stylesheet'>
<title>UteNation  -  Inside the Numbers: BYU</title>
<meta content='UteNation  -  Inside the Numbers: BYU' property='og:title'>
<meta content='A deep dive analysis into BYU&#39;s team ' name='description'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-3e35aed6375aafe36358d97418c7b1a761e93998da858c6d39683883c8789ba8.css" />


<script src="https://cdn.rivals.com/production/assets/lib-6c022b93a90b8980b59dc8365df99c024fc31b928721a316b58736a1fa13e26e.js"></script>
<script src='/javascript/config.js'></script>
<script src="https://cdn.rivals.com/production/assets/application-b54499eb24c1ec8c6a8968f484926a6e94ec3f0e904275b7b7552011ca7732b8.js"></script>

<script src='/javascript/url_factory.js'></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="2OuJ6fkhLBI+Zzx7B4jnf1VYcQ90BWFx3aTtJ17h/gNJF3rsiOsEUwbW3PW1Ain/rEhMT66Cn2CQt4kZrFlhkA==" />
<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-fdff72b91f19d75cf51d8bdb22cf7f1c7435213329db92847ab8cd17911cc566.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-171b5725637bfa4769cee9b7c9352a74b2ba24d525be5b720e267e8adf48012c.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://utah.rivals.com/news/inside-the-numbers-byu-1' property='og:url'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/rv779wu9vxd034iisv8l' property='og:image'>
<meta content='A deep dive analysis into BYU&#39;s team ' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2021-09-10 15:58:10 -0500' property='article:published_time'>
<meta content='2021-09-10 15:58:11 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-79d2adbade85e1e68905ea1a26278770384c72769e302a0dae0424b3991cb8c0.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-fad0448de054b018c1fb496c82e4d147e36e025324f6097d939a6223773c6408.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-d83a481672df92fa565a3c3e4490fe8538a8cca8f2f6c8bc04b4e003da9c1f95.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-dde27fd6889cda35c548e8f311394eb5ad38fd060061150fb984469c56db0a8d.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-1b293697db4809dca023fcaee39f7266c5278095067b8f6c8edb1bcc1cf9029a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-160b06011cecdf794bd4037752e257bf4272d38e105b58b8b63ff4e510d25a7a.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-b53ef0fb1afaa6ee435ba26728402dd43f9f2853b6a2932fa7d9fb70fc5e35ce.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-95c2973fbaef93d4c790667ba039b95898451bb04f5b2b399071e6483347812d.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-a223232b426f12e2f04f4a3aecf49f46b9e0a79cd886e7a210e0cdf5ad5bd024.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-a217ac85d423e19cbde56dcf9b01630789a023d0509d6fa0880bd5da15cc22d1.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-894aa91cf9d624f18d121145468a0bb30395f01d70de0dbf67742b95de46cfd2.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-b0f9dfc4ee4c3780ac01665cf518b0b20ec78f58b81349f7cbcf715820137ac3.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-8ab5e15036ae6a8e5c073b018e034b9e1d8b57c0445d930c005e3bbd54bdf23e.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-c5cfe3c55f53109b71f4a7ed03d0ff07134dc883a367e64241c5c595468da9bb.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-4bf9998442db4c04360a1612c42ca4e1aeff88b16510ab66fc9275af3e694668.json' rel='manifest'>
<rv-chartbeat-config-header ng-hide subdomain='utah.rivals.com'></rv-chartbeat-config-header>

</head>
<body class='utah contents-show' ng-app='rivals'>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PHNjcmlwdD4KICAoZnVuY3Rpb24odyxkLHMsbCxpKXsKICAgICAgICBpZiAo
d2luZG93Ll9kaWRBc3luY0luamVjdEdvb2dsZVRhZ01hbmFnZXIpIHJldHVy
bjsKICAgICAgICB3W2xdPXdbbF18fFtdO3dbbF0ucHVzaCh7J2d0bS5zdGFy
dCc6CiAgICAgICAgbmV3IERhdGUoKS5nZXRUaW1lKCksZXZlbnQ6J2d0bS5q
cyd9KTt2YXIgZj1kLmdldEVsZW1lbnRzQnlUYWdOYW1lKHMpWzBdLAogICAg
ICAgIGo9ZC5jcmVhdGVFbGVtZW50KHMpLGRsPWwhPSdkYXRhTGF5ZXInPycm
bD0nK2w6Jyc7ai5hc3luYz10cnVlO2ouc3JjPQogICAgICAgICdodHRwczov
L3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNvbS9ndG0uanM/aWQ9JytpK2RsKycm
Z3RtX2F1dGg9JysnS2hINmhlQ3BvV0pVSG5xVnpkRWE3dycrCiAgICAgICAg
JyZndG1fcHJldmlldz0nKydlbnYtMScrJyZndG1fY29va2llc193aW49eCc7
Zi5wYXJlbnROb2RlLmluc2VydEJlZm9yZShqLGYpOwogICAgICAgIHdpbmRv
dy5fZGlkQXN5bmNJbmplY3RHb29nbGVUYWdNYW5hZ2VyID0gdHJ1ZTsKICAg
ICAgfSkod2luZG93LGRvY3VtZW50LCdzY3JpcHQnLCdkYXRhTGF5ZXInLCdH
VE0tTUY2UFhYQycpOwo8L3NjcmlwdD4KPG5vc2NyaXB0Pgo8aWZyYW1lIGhl
aWdodD0nMCcgc3JjPSdodHRwczovL3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNv
bS9ucy5odG1sP2lkPUdUTS1NRjZQWFhDJmFtcDtndG1fYXV0aD1LaEg2aGVD
cG9XSlVIbnFWemRFYTd3JmFtcDtndG1fcHJldmlldz1lbnYtMSZhbXA7Z3Rt
X2Nvb2tpZXNfd2luPXgnIHN0eWxlPSdkaXNwbGF5Om5vbmU7dmlzaWJpbGl0
eTpoaWRkZW4nIHdpZHRoPScwJz48L2lmcmFtZT4KPC9ub3NjcmlwdD4KCgo=

</div>
</div>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-83298012-1', 'auto');
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .utah #programming > h1 {
      background-color: #bdbdbd !important; } }
  
  .utah .wrapper-container .team-colors-line {
    background-color: #cc0000; }
  
  @media screen and (min-width: 768px) {
    .utah .solid-team-line {
      width: 100%;
      height: 8px;
      display: flex;
      background-color: #cc0000; } }
  
  .utah .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #bdbdbd; }
    .utah .team-colors-line .color {
      width: 33.33%; }
    .utah .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .utah .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .utah .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .utah .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .utah .team-colors-line.header {
      height: 6px; }
  
  .utah > header .notification-link .count-container {
    background-color: #bdbdbd !important; }
  
  .utah > header .wrapper-container {
    background-color: #bdbdbd !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
  
  .utah > header .invalid-email-banner {
    background-color: #bdbdbd;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .utah > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .utah > header .invalid-email-banner a:hover {
      color: #cc0000; }
  
  @media screen and (max-width: 767px) {
    .utah > header .mobile-header {
      background-color: #cc0000 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  
  .utah > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  
  .utah > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  
  .utah > header .second-nav {
    background-color: white !important; }
  
  @media screen and (max-width: 1023px) {
    .utah > header .nav-row > ul,
    .utah > header .third-nav {
      background-color: white !important; }
    .utah > header .dropdown-toggle > i.fa {
      color: #bdbdbd !important; } }
  
  .utah > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #bdbdbd; }
  
  .site-primary-font-color {
    color: #bdbdbd; }
  
  .site-primary-background-color {
    background-color: #bdbdbd; }
  
  .site-secondary-font-color {
    color: #cc0000; }
  
  .site-secondary-background-color {
    background-color: #cc0000; }
  
  :root {
    --primary-color: #bdbdbd;
    --primary-color-overlay: rgba(189, 189, 189, .4);
    --secondary-color: #cc0000;
    --accent-color: #bdbdbd;
    --button-color: #bdbdbd;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init("utah")' role='navigation'>
<div class='wrapper-container'>
<a class='cta-header-banner' ng_href='{{ctrl.subscribePath}}' style='display: none;'>
Enjoying UteNation? Get a yearly subscription for $99.95/year or $9.95/month
</a>
<div class='wrapper logo-row'>
<a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
</a><a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
<a alt="Utah" class="site-header logo-image-wrapper" href="https://utah.rivals.com/"><img src="https://images.rivals.com/image/upload/f_auto,q_auto/x8yfrpuu76xfy1gd7tny" />
</a><div class='nav-right-controls'>
<div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
<span class='upsell-text'>
Join the team!
</span>
<div class='subscribe-button' ng-click='ctrl.subscribeEvent()'>
Subscribe
</div>
</div>
<rv-universal-search></rv-universal-search>
<rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
<rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
</div>
</div>
<div class='solid-team-line header'></div>
</div>
<div class='mobile-header'></div>
<rv-header-alert class='alert-nav'></rv-header-alert>
<hr>
<div class='nav-row-container'>
<div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://utah.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;utah&#39;" limit="8"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://utah.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;utah&#39;" limit="4"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
<a ng-href='{{ctrl.userProfileEditPath}}'>
Your account has an invalid email address. Please update it here.
</a>
</div>
</div>
</nav>
</header>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid3.js"></script>
<script src='/javascript/ad_beacon.js?path=content&space_id=2022733164' type='text/javascript'></script>

<rv-content-title content-title='Inside the Numbers: BYU' ng-hide='true'></rv-content-title>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@MSaltasRivals' name='twitter:site'>
<meta content='Inside the Numbers: BYU' name='twitter:title'>
<meta content='A deep dive analysis into BYU&#39;s team ' name='twitter:description'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_large/rv779wu9vxd034iisv8l' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {&quot;id&quot;:153,&quot;legacy_id&quot;:1141,&quot;name&quot;:&quot;UteNation&quot;,&quot;friendly_name&quot;:&quot;Utah&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;utah&quot;,&quot;primary_color&quot;:&quot;bdbdbd&quot;,&quot;secondary_color&quot;:&quot;cc0000&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;utah&quot;,&quot;maple_ncaaf_team_id&quot;:94,&quot;maple_ncaaf_endpoint&quot;:&quot;ncaaf/teams/uuc&quot;,&quot;maple_ncaab_team_id&quot;:610,&quot;maple_ncaab_endpoint&quot;:&quot;ncaab/teams/uae&quot;,&quot;maple_college_id&quot;:94,&quot;google_analytics_id&quot;:&quot;UA-83298012-1&quot;}, true, 239, nil, {&quot;id&quot;:144,&quot;primary_color&quot;:&quot;bdbdbd&quot;,&quot;secondary_color&quot;:&quot;cc0000&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;commitment_module_football&quot;:true,&quot;rivals_module_football&quot;:true,&quot;header_name&quot;:&quot;&quot;,&quot;header_logo_cloudinary&quot;:&quot;x8yfrpuu76xfy1gd7tny&quot;,&quot;mobile_header_logo_cloudinary&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-83298012-1&quot;,&quot;logo_background_shading&quot;:&quot;white&quot;,&quot;football_content&quot;:true,&quot;basketball_content&quot;:true,&quot;baseball_content&quot;:true,&quot;other_content&quot;:true,&quot;site_id&quot;:153,&quot;created_at&quot;:&quot;2016-11-23T13:38:44.924-06:00&quot;,&quot;updated_at&quot;:&quot;2021-04-16T12:39:37.633-05:00&quot;,&quot;max_trending_articles&quot;:6,&quot;enrichments&quot;:[{&quot;active&quot;:true,&quot;type&quot;:&quot;Commitment&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:1},{&quot;active&quot;:true,&quot;type&quot;:&quot;Rivals&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:2},{&quot;active&quot;:false,&quot;type&quot;:&quot;Schedule&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Twitter&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:true,&quot;type&quot;:&quot;TeamRankings&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:3},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardScores&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardPhotos&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;FanFuturecastLeaderboard&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;RecentForecasts&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null}],&quot;footer_text&quot;:null,&quot;sections&quot;:[],&quot;supplied_domain&quot;:null,&quot;forums_link_url&quot;:&quot;https://utah.forums.rivals.com/forums/inside-ute-nation.10/&quot;,&quot;scoreboard_scores_id&quot;:null,&quot;scoreboard_photos_id&quot;:null,&quot;aol_player_id&quot;:&quot;5965069af3bdc926ec4fdcb0&quot;,&quot;aol_company_id&quot;:&quot;595ee28c2a30cb7ee3e53976&quot;,&quot;ad_frequency&quot;:5,&quot;display_twitter_follow&quot;:true,&quot;display_fb_follow&quot;:false,&quot;follow_twitter_handle&quot;:&quot;Utah_Rivals&quot;,&quot;follow_fb_handle&quot;:null,&quot;forum_id&quot;:null,&quot;premium_forum_id&quot;:null,&quot;facebook_page_id&quot;:null,&quot;max_ticker_articles&quot;:8,&quot;schedule_header_on&quot;:false,&quot;promo_popup_on&quot;:false,&quot;facebook_developer_id&quot;:null,&quot;customized_tos&quot;:[],&quot;show_survey_popup&quot;:false,&quot;survey_popup_link&quot;:null,&quot;header_bottom_border_style&quot;:&quot;solid&quot;,&quot;customized_upsell_banner_text&quot;:null,&quot;email_logo_cloudinary&quot;:null,&quot;target_list_on&quot;:null,&quot;gifting_banner_content&quot;:&quot;Give a Rivals gift subscription this holiday season&quot;,&quot;gifting_banner_title&quot;:&quot;The perfect gift for football recruiting fans!&quot;,&quot;gifting_banner_button_text&quot;:&quot;Give a gift subscription&quot;,&quot;navigation_key&quot;:&quot;utah&quot;},
&quot;5965069af3bdc926ec4fdcb0&quot;, &quot;595ee28c2a30cb7ee3e53976&quot;, &quot;rivals&quot;, 15000,
false, {&quot;id&quot;:1903,&quot;user_id&quot;:2412916,&quot;site_id&quot;:153,&quot;updated_at&quot;:&quot;2021-06-05T00:21:04.426-05:00&quot;,&quot;publisher_name&quot;:&quot;Sean Davenport&quot;,&quot;first_name&quot;:&quot;Sean&quot;,&quot;last_name&quot;:&quot;Davenport&quot;,&quot;site_title&quot;:&quot;Ute Nation&quot;,&quot;bio&quot;:&quot;&quot;,&quot;twitter_handle&quot;:&quot;SeanDavenport&quot;,&quot;image_url&quot;:null,&quot;publisher_name_and_title&quot;:&quot;Sean Davenport, Ute Nation&quot;,&quot;site_name&quot;:&quot;UteNation&quot;,&quot;site_short_name&quot;:&quot;utah&quot;,&quot;has_edited_profile&quot;:true}, null)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{&quot;no-ad-padding&quot;: &quot;#{@display_ldrb_top}&quot;}'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode' site_name='UteNation'></rv-news-ticker>
</div>

<rv-forums ad-referer='https://utah.rivals.com/news/inside-the-numbers-byu-1' base-api-url='https://utah.forums.rivals.com/' forums-url='https://utah.forums.rivals.com/forums/inside-ute-nation.10/' homepage='false' pub-ad='null' size='size' space-id='2022733164' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='article-display-wrapper'>
<div class='mobile-ad native-ad-ccc25e1a-d33c-46c9-a14a-96144b7a8b28'></div>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://utah.rivals.com/news/inside-the-numbers-byu-1/printable' site-name='UteNation'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo(&#39;2021-09-10 15:58:10 -0500&#39;) }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2312799/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h1 class='article-title'>Inside the Numbers: BYU</h1>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/rv779wu9vxd034iisv8l&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/rv779wu9vxd034iisv8l&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="" alt="" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/rv779wu9vxd034iisv8l" />
<div class='zoom-image'></div>
</div>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='title-sm' id='onetime-author'>Dustin Birch</div>
<div class='type-sm'>Staff Writer, Ute Nation</div>
</div>

<div class='mobile-ad'>
<div class='native-ad-50d38545-0eeb-4c35-9393-b22cf70b9e3d'></div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>The Holy War. The In-State Game. It's here. After last week’s win over Weber State, the Utes travel down south to Provo. Today, we look a bit closer at BYU. The teams BYU beat last season went a combined 45-55, with very few of them played a full schedule, unlike BYU. Still, it was a great season for the Cougars and as a result they lost a lot of contributors for this year’s squad. In this article, we’ll talk a little bit about those losses, who is coming back, and take a deep analysis of who returns for BYU with Pro Football Focus (PFF) numbers to help.</p><p><b>Who they lost on offense</b></p><p><b>QB - Wilson:</b> This is the big one. He was rated 95.4 by PFF last year (#2 on the offense), played 711 snaps, and went 247/336 (73.5%) for 3,692 yards (11 ypa) with 33 TD and 3 INT. Those are incredible numbers, even against their less than stellar schedule. Wilson accounted for 91.1% of last year’s QB completions, 93.4% of last year’s QB passing yards, and 97.1% of last year’s passing TDs. Wilson was drafted #2 overall to the New York Jets.</p><p><b>OT - Christensen: </b>He was rated 95.9 last year (#1 on the offense) and played 741 snaps at LT. He was drafted in the third round by the Carolina Panthers. </p><p><b>OG - Herring: </b>He was rated 82.2 last year (#5 on the offense) and played 707 snaps at RG/LG/RT. He was a UFA who spent some time with the Tennessee Titans, but didn’t make the active roster.</p><p><b>OG - Hoge: </b>Rated 82.0 last year (#7 on the offense) and played 413 snaps at RG. He was a UFA who spent some time with the Jets. He didn’t make the active roster.</p><p><b>OG - Longson: </b>Longson only played 135 snaps last year, mostly at RG, but was rated average at 69.6. He chose to not return for an extra senior season.</p><p><b>WR - Milne: </b>Rated 90.0 last year (#4 on the offense) and played 546 snaps. He had 70 receptions (25.5% of last year’s total), 1,188 yards (30.1% of last year’s total), for 17 ypc with 8 TD (23.5%). He was drafted in the 7th round by the Washington Football Team.</p><p><b>Who they lost on defense</b></p><p><b>DE - Dawe: </b>Rated 78.2 (#2 on the team and #1 of the starters) and played 575 snaps. He had 43 tackles (#6 on team, 5.9% of the total), 7 TFL (#1 on team) with 2 sacks. Picked up by the Atlanta Falcons as a UFA, but didn’t make the active roster.</p><p><b>DE - Fevaleaki: </b>Rated 81.1 (#1 on the team) on 100 snaps. He was a backup, but played very well in limited action. Had 6 tackles, 1 TFL, 1 sack and 1 PBU. Fevaleaki entered the transfer portal this past summer, landing at Snow College.</p><p><b>DE/DT - El-Bakri: </b>Rated 63.5 and played 453 snaps. He had 49 tackles (#4 on the team, 6.7%), 3.5 TFL, and 1.5 sacks. He chose to declare for the NFL draft instead of returning for another senior season, but he was not picked up by a team.</p><p><b>DT - Tonga: </b>Rated 71.7 (#9 on the team) and played 465 snaps. He had 36 tackles (#8 on the team, 5.0%), 3.5 TFL, 3.5 sacks, 5 PBU and 1 FF. He was drafted in the 7th round by the Chicago Bears and is currently on the roster. </p><p><b>OLB - I. Kaufusi: </b>Rated 63.9, he played 570 snaps. He had 83 tackles (#1 on the team and 11.4%), 3.5 TFL, 2 sacks, 1 INT, 1 PBU, 3 FF and 2 FR. He was picked up as a UFA by the Indianapolis Colts, but didn’t make the roster.</p><p><b>CB - Wilcox: </b>Rated 68.3, he played 385 snaps. He had 18 tackles (#15 on team, 2.5%) and 1 PBU. He was drafted in the 7th round by the Buccaneers, but eventually was picked up by the Colts and made their roster.</p><p><b>CB/S - Fonua: </b>Rated 52.3, he played 304 snaps. He had 28 tackles (#9 on team, 3.9%), 2 TFL and 3 PBU plus 1 FF. He graduated and left, but didn’t get any NFL contracts.</p><p><b>S - Warner: </b>Rated 77.5 (#4 on team) and played 661 snaps (#1 on team). He had 28 tackles (#9 on team, 3.9% of the total), 1.5 TFL, 2 INT and 2 PBU. Picked up as a UFA with the Los Angeles Rams, he didn’t make the active roster.</p><p><b>S - Anderson:</b> Rated 64.0 by PFF, he played 485 snaps at FS. He had 41 tackles (#7 on team, 5.6% of the total) and 2 PBU. Not a great rating from PFF, but he still got a free agent shot with the Kansas City Chiefs, but he didn’t make the roster.</p><p><b>Here are the losses due to injury for this game</b></p><p><b>WR - Romney: </b>Romney was injured against Arizona in BYU’s first game this season. There’s no way Romney plays this week, but he’s not lost for the season. He was rated 79.3 last year (#9 on the team) and had 39 receptions (14.3%) for 603 yards (15.3%) and 2 TD (5.9%). He had what appears to be a severe MCL sprain or mid-grade tear.</p><p><b>CB - Ellis: </b>Ellis was injured against Arizona in a very scary situation, but it appears he’s okay with no pain and a negative CT. I still don’t expect him this week, but it’s possible he’ll be cleared. He was rated 67.5 last year with 287 snaps. He had 13 tackles (#18, 1.8%) and 3 PBU.</p><p><b>CB - Udo: </b>Udo was hurt last year and then suffered a setback during fall camp. He won’t be playing this week. He was rated 76.0 by PFF (#5 on the team) on 227 snaps. Despite a lower number of snaps, he had 25 tackles (#12 on team, 3.4%), 5.5 TFL, 3 sacks and 1 PBU.</p><p><b>CB - Harper: </b>Harper was hurt in the spring and is out probably most of the season with a knee injury. He was rated 65.9 last year on 377 snaps. He had 25 tackles (#12 on team, 3.4%), 1.5 TFL and 1 PBU.</p><p><br></p><p>That is a TON of losses. There almost certainly won’t be another team the Utes face this year that lost as much as BYU. They lost the following production from the 2020 team:</p><p>91.1% QB completions</p><p>93.4% QB passing yards</p><p>97.1% passing TDs.</p><p>39.8% receptions</p><p>45.4% receiving yards</p><p>21.6% rushing attempts</p><p>20.8% rushing yards</p><p>54.3% tackles</p><p>48.5% TFL</p><p>60.9% sacks</p><p>37.5% INT</p><p>51.3% PBU</p><p><br></p><p>Now, who's returning for the offense from last year, plus some new faces we’ll see this year based on last week’s game against the Arizona Wildcats.</p><p><b>Who's returning for the offense</b></p><p><b>QB - Hall: </b>Hall has played a total of 208 snaps, including the 64 snaps last week. He was rated 71.2 last week and his career numbers are 49/74 (66.2%) for 618 yards (8.4 ypa) for 3 TD and 0 INT. Those numbers are against Arizona this year and against USF and USU in 2019. He’s also an effective runner, with 31 designed rushes for 217 yards (5.9 ypc) with 3 TD and 2 fumbles. Based on last week, BYU probably won’t have him run very much, but it’s something that Utah will have to watch.</p><p><b>RB - Allgeier: </b>Allgeier played 39 snaps last week and was rated 67.1, going 17/94 (5.5 ypc) with 1 TD. Overall, he has 499 snaps and his career numbers are 193/1,392 (7.2 ypc) with 14 TD. Most of those snaps were against last year’s schedule, so it’s hard to say how good he is. Still, he’s an effective runner and is pretty fast in space.</p><p><b>RB </b>-<b> Katoa: </b>Katoa played 25 snaps last week and was rated 71.6, going 9/33 (3.7 ypc) Overall, he has 1,050 snaps and his career numbers are 254/1,258 (5.0 ypc) for 17 TD. He tends to be BYU’s short-yardage back, but last year these two split snaps pretty evenly (324 for Katoa, 382 for Allgeier) but Allgeir got nearly double the carries (Katoa had 84, Allgeier had 150).</p><p>The RBs are a solid group. Allgeier is a good back with good speed, and Katoa is experienced and tough to bring down. They’re better than a lot of BYU backs we’ve seen over the years, but we aren’t seeing the second coming of Jamaal Williams.</p><p><b>WR - Pau’u: </b>Pau’u played 57 snaps last week and was rated 84.4 (#1 on the team). He had 8 receptions for 126 yards (15.8 ypc) and 2 TD. He has 1,057 snaps overall and his career numbers are 85/1,084 (12.8 ypc) and 9 TD. Expect him to be the go-to receiver unless he’s seriously hurt (he’s been seen in a boot this week). Hall doesn’t have experience with the Nacuas, but he’s played with Pau’u for four years and seemed to trust him last week.</p><p><b>WR - S. Nacua: </b>Samson hasn’t played for BYU yet, as both he and Puka were held out last week with lower leg injuries. Samson played 987 snaps in 4 years for Utah (averaging about 290 snaps a year in regular years). His best year was 2018, when he was rated 71.6. In 4 years he had 82 catches for 1,015 yards (12.4 ypc) with 11 TD.</p><p><b>WR - P. Nacua: </b>Puka hasn’t played for BYU yet either, but played a little bit for UW (203 snaps). So far his college career has been less impressive than his potential, although he was rated 73.1 in his best year (2019). In 2 years he’s caught 16 passes for 319 yards (19.9 ypc) with 3 TD. Still, he was a highly sought-after recruit for a reason. If Hall can get him the ball, he’s dangerous.</p><p><b>WR - Jackson: </b>Jackson is Romney’s backup, but I expect to see the Nacuas more than Jackson. He played 34 snaps and was rated 64.5 last week, with 2 catches for 20 yards (10 ypc). In his career he has 167 snaps, 8 catches for 42 yards (5.3 ypc). </p><p><b>WR - Hill: </b>Hill played 47 snaps last week and was rated 62.7. He had 3 catches for 22 yards (7.3 ypc). For his career he has 207 snaps, 10 catches for 132 yards (13.2 ypc) with 1 TD last year. I don’t expect to see nearly as much of him this week with the Nacuas back.</p><p>Pau’u is a good WR, but I fully expect Utah to be able to cover him. The question is whether the Utes can cover Puka on the other side as well. Romney is also a good WR, and Jackson is serviceable. If Romney is on the field, they have three or four capable receivers including one potential superstar in Puka.</p><p><b>TE - Rex: </b>Rex played 60 snaps last week and had 2 catches for 9 yards and was rated 53.5. That’s a very poor rating for PFF, and significantly behind where he was rated last year (70.3). For his career, he has 714 snaps, 40 catches for 461 yards (11.5 ypc) with 12 TD. BYU fans love Rex, and he’s a decent TE, but Utah’s defense has experience defending one of the best tight end units in the country, so they should be able to keep up with BYU’s group.</p><p><b>TE - Wake: </b>Wake played 34 snaps last week and had 1 catch for 10 yards. He was rated 58.1, another subpar rating and significantly behind last year’s number (73.3). For his career, he’s played 414 snaps and has 9 receptions for 124 yards (13.8 ypc) with 1 TD.</p><p>BYU fans love their TEs, but they’re not as scary as their wide receiver group. Expect Utah’s linebackers and safeties to be able to keep them largely contained, just like Arizona did last week.</p><p><b>LT - Freeland: </b>Freeland played the entire game (64 snaps) and was rated 67.7, which is average. Freeland is decently experienced (1,019 snaps), but the last two years he’s played RT, not LT.</p><p><b>LG - Barrington: </b>Played the entire game (64 snaps) and was rated 61.5, which is below average. He’s also decently experienced (981 snaps) and started all of last year, as well as some of 2019.</p><p><b>C - Empey: </b>Empey also played the entire game last week (64 snaps) and was their highest-rated OL at 69.2. He’s their most-experienced OL with 2,289 snaps, and has been starting four straight years (although he missed some games last year with injury). He’s their best lineman and still leaves some Ute fans wondering about “what could have been” if he stuck with his commitment to Utah.</p><p><b>RG - Pay: </b>Pay started at RG and played the first 27 snaps last week. He was rated 64.3, which is not great. I think he was pulled for performance, not injury, and he’s still #1 on the depth chart. He had 112 snaps last year for a total of 139 (their least-experienced OL).</p><p><b>RT - LaChance: </b>LaChance played the entire game (64 snaps) at RT and was rated 54.4 (their second-worst OL). He’s played a little bit, but still only has 359 snaps to his name. Expect Utah’s Carlton and Fillinger to make life difficult for LaChance on the edge.</p><p><b>RG - Tukuafu: </b>Tukuafu stepped in when Pay came out and played 37 snaps. He was rated 53.1, their worst-rated OL. He has 378 snaps in his career, mostly at C when Empey was out with injury. He’s also not performing well, which is why Pay is getting more time, as he’s a freshman and Tukuafu is a junior.</p><p>Overall, the offensive line is okay. The left side is decent, Empey is good and will probably get a shot at the NFL, but the right side is bad. Expect BYU’s TE to end up on the right side a lot to help the right side of the OL. Watching some highlights from the Arizona game, I’d estimate the TE lined up on that side about 70% of the time.</p><p><br></p><p>The offense appears to be… okay. They have one good WR (Pau’u), one possibly elite WR if he plays to his potential (Puka), and one reliable WR (Samson). Their TE and RB are not as good as they think, but they’re not bad. Their OL is good on the left and very bad on the right. </p><p>The question really is their quarterback play. We don’t have enough information to tell us whether or not Hall is any good. He had a couple of very good throws against Arizona and a few really bad throws. Expect him to be facing a lot more pressure this week and expect Utah’s young DEs to be involved in a lot of that pressure.</p><p><b>Who returns on defense</b></p><p>One note, BYU’s depth chart lists 5 starting DL, 4 starting LB, and 6 starting corners. I’m going to assume they’re playing a 4-3 and go based on snaps (not who actually started).</p><p><b>DE - Batty: </b>Batty played 66 snaps against Arizona and was rated 53.8, which was second-lowest of BYU’s starters. He had 4 tackles and 1 sack, plus 2 QB hurries. He also played 96 snaps last year, for a total of 162 snaps. His career numbers are 17 tackles, 4.5 TFL, and 4.5 sacks.</p><p><b>DE - Leiataua: </b>Leiataua played 47 snaps against Arizona and was rated 72.0 (I would call this #2 among the starters, although Leiataua technically didn’t start, they started Batty at DE and 3 DTs). He had 3 tackles and 1 sack last week plus 3 QB hurries. Leiataua is their second-most experienced defensive lineman, playing 632 snaps. He has 46 career tackles, 6 TFL, 3.5 sacks and 1 PBU.</p><p><b>DE - Fauatea: </b>Fauatea is listed as the starter at SE. He played 28 snaps against Arizona and was rated 50.6 with 1 tackle. He’s their most-experienced defensive lineman with 726 snaps. For his career he has 39 tackles, 6 TFL, 4.5 sacks, and 2 PBU.</p><p><b>DE/LB - Tanavusa: </b>Tanavusa played 22 snaps against Arizona and was rated 67.5, which is an average rating. He had 1 tackle. For his career, he’s played 448 snaps and has 57 tackles, 2 TFL, 1 sack, 1 INT, and 3 PBU.</p><p><b>DT - Tuioti-Mariner: </b>Tuioti-Mariner played 49 snaps and was rated 63.2, which is just below average. He had no official stats, but did have 3 QB hurries. He has 555 career snaps and 23 career tackles.</p><p><b>DT - Summers: </b>Summers played 49 snaps and was rated 66.1. He had 4 tackles, 2 QB hurries and one QB hit. He’s played a little bit, with 428 career snaps, 27 career tackles, 4 TFL, and 2 sacks.</p><p><b>DT - Mahe: </b>Mahe played 27 snaps against Arizona and was rated 58.7. He had 2 tackles and 1 QB hurry. He has 282 career snaps and 24 tackles, 3 TFL, and 2 sacks.</p><p>BYU’s defensive line was rated average or bad against Arizona at every spot outside of Leiataua. BYU brought a lot of pressure, but that appears to be a necessity, not a product of being aggressive. They’re also fairly inexperienced outside of Leiataua and Fauatea.</p><p><b>LB - Wilgar: </b>Wilgar played 69 snaps and was rated 70.9, which is pretty good. He had 9 tackles, 2 TFL, 1 sack, and 3 QB hurries and was the top-rated LB against Arizona. In his career, Wilgar has 1,283 snaps, 120 tackles, 11.5 TFL, 1 sack, 3 INT, and 5 PBU. Expect him to get a lot of work covering TE/RB, as he’s BYU’s best coverage LB by far.</p><p><b>LB - Pili: </b>Pili played 72 snaps and was rated 65.4, which is okay. He had 17 tackles (#1 in the nation), 1 sack, and 1 QB hurry. He’s played 782 snaps in his career, 115 tackles, 7 TFL, 2 sacks, and 3 PBU.</p><p><b>LB - Tooley: </b>Tooley was held out against Arizona but is expected to play against Utah. He has played 750 career snaps and was rated 65.9 last year. His career numbers are 94 tackles, 5 TFL, 2 INT and 2 PBU.</p><p><b>LB - Bywater:. </b>Bywater played 55 snaps in place of Tooley and was rated 43.9, the worst starter by far. He had 10 tackles but was very bad in coverage, giving up nearly 100 yards and a touchdown. He’s played 133 snaps in his career and has 25 tackles.</p><p>The starting linebackers are decent, but the depth looks rough if Bywater is their best backup option. As with the Nacuas, I expect Tooley to play, but I don’t know if he’s 100%. If Bywater is playing a significant number of snaps, expect Ludwig to get him matched up on a RB or TE and abuse him in the passing game.</p><p><b>CB - Mandell: </b>Mandell played 71 snaps and was rated 70.0, which is decent and is tied for the best rating among their corners. He had 5 tackles last week against Arizona. He has 985 career snaps but has never rated above 60.5 by PFF for an entire season. His career numbers are 41 tackles, 2.5 TFL, and 1 PBU.</p><p><b>CB - Herron: </b>Herron played 49 snaps and was rated 70.0, tied for first among corners with Mendell. He had 2 tackles and 1 PBU. He has 674 career snaps, 37 tackles, 2 TFL and 7 PBU.</p><p><b>CB - Robinson: </b>Robinson played 49 snaps and was rated 69.7. He had 3 tackles. He played 86 tackles for USU last year and has 11 career tackles and 1 sack.</p><p><b>CB - Hayes: </b>Hays played 42 snaps and was rated 61.6 last week, but had no stats. This is his first year at BYU, playing at Oregon State since 2018. He played 624 snaps before being injured in 2019. He had 46 tackles and 8 PBU for the Beavers.</p><p>The corners are okay. They don’t give up big plays and keep everything in front of them. Because of that, the defense gave up almost 350 yards in the air, but only a few passes over 20 yards. But they also don’t force turnovers and don’t get the offense off the field quickly because they play such soft zones. </p><p><b>S</b> <b>- Ah You: </b>Ah You is BYU’s best player. He played 75 snaps and was rated 78.7. He had 9 tackles and 1 PBU last week. For his career, he has only 556 snaps because he was splitting time in 2019 and was hurt early in 2020. He appears to have recovered from that injury and looked fully capable against Arizona. He has 51 career tackles, 6.5 TFL, 1 sack, 1 INt and 4 PBU.</p><p><b>S</b> <b>- Moore: </b>Moore played 67 snaps and was rated 62.3, which isn’t great. He had 1 tackle. He’s played 462 snaps and has 24 tackles, 2 INT and 1 PBU. </p><p>Ah You is very good and Moore is average, according to PFF. Expect Moore to be playing deep and Ah You to be covering TEs and RBs and playing in the middle.</p><p><br></p><p>So that’s BYU. They’re untested at QB, slightly above average at RB, have some weaknesses at OL, have a ton of potential at WR but still unknown, and have good but not great TEs. On defense their line is suspect, their linebackers and corners are average, and one safety is very good, while the other is just okay. I expect them to try and pass a lot, because I don’t see them running on Utah’s front seven. BYU’s receivers could get past Utah’s secondary a couple of times for long pass plays, but Utah should control both running and passing. After looking at the team, I’m expecting a little bit more scoring than normal rivalry games.</p><p><b>Prediction:</b> Utah 37, BYU 24.</p><p><br></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://utah.rivals.com/news/inside-the-numbers-byu-1/printable' site-name='UteNation'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === &quot;premium&quot;'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>

<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' display-lrec1-rightrail='true' display-lrec2-rightrail='true' display-lrec3-rightrail='true' enrichments='[{&quot;active&quot;:true,&quot;type&quot;:&quot;Commitment&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:1},{&quot;active&quot;:true,&quot;type&quot;:&quot;Rivals&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:2},{&quot;active&quot;:true,&quot;type&quot;:&quot;TeamRankings&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:3,&quot;footballYear&quot;:2022,&quot;basketballYear&quot;:2022}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2021' ncaaf-schedule-year='2021' site='{&quot;id&quot;:153,&quot;legacy_id&quot;:1141,&quot;name&quot;:&quot;UteNation&quot;,&quot;friendly_name&quot;:&quot;Utah&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;utah&quot;,&quot;primary_color&quot;:&quot;bdbdbd&quot;,&quot;secondary_color&quot;:&quot;cc0000&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;utah&quot;,&quot;maple_ncaaf_team_id&quot;:94,&quot;maple_ncaaf_endpoint&quot;:&quot;ncaaf/teams/uuc&quot;,&quot;maple_ncaab_team_id&quot;:610,&quot;maple_ncaab_endpoint&quot;:&quot;ncaab/teams/uae&quot;,&quot;maple_college_id&quot;:94,&quot;google_analytics_id&quot;:&quot;UA-83298012-1&quot;}' twitter-feed='{&quot;id&quot;:152,&quot;site_id&quot;:153,&quot;handle&quot;:&quot;@MSaltasRivals&quot;,&quot;list_name&quot;:&quot;&quot;,&quot;created_at&quot;:&quot;2016-02-01T12:25:33.009-06:00&quot;,&quot;updated_at&quot;:&quot;2018-06-23T11:14:07.091-05:00&quot;,&quot;hashtags&quot;:[],&quot;usernames&quot;:[],&quot;max_number&quot;:0}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://utah.rivals.com/news/inside-the-numbers-byu-1/printable' site-name='UteNation'></rv-share-links>
</div>
</div>
</div>
<script src='/javascript/ad?ad_referrer=https%3A%2F%2Futah.rivals.com%2Fnews%2Finside-the-numbers-byu-1&amp;space_id=2022733164' type='text/javascript'></script>

<rv-chartbeat-config-body ng-hide sections='content,content-football,content-football-free,content-article' title='Inside the Numbers: BYU'></rv-chartbeat-config-body>

<script>
dataLayer = [{"u15":"utah","u16":2312799}];

</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if='showLRECad(&#39;footer&#39;)'>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
</div>

</div>
</main>
<script src='/javascript/pencil_ad.js'></script>
<script src='/javascript/stream_ad.js'></script>
<script src='/javascript/moments_ad.js'></script>
<footer>
<div class='flexible-links'>
<a class='link' href='/news/about-us'>About</a>
<a class='link' href='/news/member-services'>Help</a>
<a class='link' href='/news/contact-us-5'>Contact Us</a>
<a class='link' href='/tos'>Terms of Service</a>
<a class='link' href='/gifts/purchase'>Gift Subscription</a>
</div>
<div class='flexible-links'>
<a class='link' href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
</div>
<div class='logo-container'>
<div class='footer-logo'><?xml version="1.0" encoding="UTF-8"?>
<svg width="159px" height="96px" viewbox="0 0 159 96" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 58 (84663) - https://sketch.com -->
    <title>logo_yahoo_sports_gray</title>
    <desc>Created with Sketch.</desc>
    <g id="Logos" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="logo-/-yahoo-sports-/-grayscale">
            <g id="logo-/-yahoo-sports-MASTER-/-black-on-white" transform="translate(0.000000, 36.000000)">
                <g id="yahoo-sports-logo-white">
                    <path d="M24.0702452,5.83111111 L24.0702452,7.06666667 C23.2097927,6.0367158 21.9427054,5.46606759 20.6261035,5.51555556 C17.1389101,5.51555556 14.5428883,8.69333333 14.5428883,12.4222222 C14.5428883,16.2577778 17.1259946,19.3333333 20.6261035,19.3333333 C21.9510266,19.3980812 23.2277754,18.8131965 24.0702452,17.7555556 L24.0702452,18.9911111 L28.4184741,18.9911111 L28.4184741,5.83111111 L24.0702452,5.83111111 Z M29.9209809,0 L29.9209809,18.9911111 L34.4241962,18.9911111 L34.4241962,11.9777778 C34.4241962,10.6088889 35.0613624,9.79555556 36.0773842,9.79555556 C37.093406,9.79555556 37.6315531,10.5066667 37.6315531,11.8177778 L37.6315531,18.9911111 L42.1347684,18.9911111 L42.1347684,10.7155556 C42.1347684,7.51111111 40.4557493,5.51555556 37.7564033,5.51555556 C36.4540592,5.4661141 35.2068557,6.0603675 34.3983651,7.11555556 L34.3983651,0.00444444444 L29.9209809,0 Z M71.1129155,12.4444444 C71.1129155,16.3866667 68.1897003,19.3555556 64.293515,19.3555556 C60.3973297,19.3555556 57.4741144,16.3866667 57.4741144,12.4444444 C57.4741144,8.50222222 60.4016349,5.53777778 64.293515,5.53777778 C68.1853951,5.53777778 71.1129155,8.50666667 71.1129155,12.4444444 Z M56.7120981,12.4444444 C56.7120981,16.3866667 53.7845777,19.3555556 49.8926975,19.3555556 C46.0008174,19.3555556 43.073297,16.3866667 43.073297,12.4444444 C43.073297,8.50222222 46.0008174,5.53777778 49.8926975,5.53777778 C53.7845777,5.53777778 56.7120981,8.50666667 56.7120981,12.4444444 Z M5.68434189e-14,5.85333333 L5.44174387,19.1155556 L3.48288828,23.8977778 L8.26594005,23.8977778 L15.5201635,5.85333333 L10.7844687,5.85333333 L7.83111717,13.5733333 L4.90359673,5.85333333 L5.68434189e-14,5.85333333 Z M21.5258856,15.1511111 C20.0778762,15.1511111 18.9040327,13.9392952 18.9040327,12.4444444 C18.9040327,10.9495937 20.0778762,9.73777778 21.5258856,9.73777778 C22.9738949,9.73777778 24.1477384,10.9495937 24.1477384,12.4444444 C24.1582975,13.1655836 23.8854595,13.8603865 23.3914592,14.3703671 C22.8974589,14.8803478 22.2244277,15.1620118 21.5258856,15.1511111 L21.5258856,15.1511111 Z M52.4155313,12.4444444 C52.3942095,10.9991882 51.2457931,9.84329333 49.8457334,9.85791214 C48.4456737,9.87253095 47.3201395,11.0521694 47.3271064,12.4975752 C47.3341381,13.942981 48.4710404,15.1109435 49.8711717,15.1111111 C50.5556752,15.1211114 51.2144344,14.8420408 51.6948283,14.3385545 C52.1752222,13.8350681 52.4355617,13.150859 52.4155313,12.4444444 Z M66.8163488,12.4444444 C66.795027,10.9991882 65.6466105,9.84329333 64.2465509,9.85791214 C62.8464912,9.87253095 61.720957,11.0521694 61.7279238,12.4975752 C61.7349555,13.942981 62.8718578,15.1109435 64.2719891,15.1111111 C64.9564926,15.1211114 65.6152519,14.8420408 66.0956458,14.3385545 C66.5760396,13.8350681 66.8363791,13.150859 66.8163488,12.4444444 Z M71.6510627,16.2266667 C71.6417293,17.0311249 71.9471656,17.80545 72.4982184,18.3743287 C73.0492712,18.9432074 73.7993326,19.2585242 74.5785831,19.2488889 C76.2429617,19.2488889 77.5922071,17.855997 77.5922071,16.1377778 C77.6063278,15.3326284 77.3030257,14.5560964 76.7518547,13.9862577 C76.2006837,13.416419 75.4489316,13.102163 74.6689918,13.1155556 C73.0046133,13.1155556 71.6553678,14.5084474 71.6553678,16.2266667 L71.6510627,16.2266667 Z M78.0657766,0.0222222222 L73.2999455,11.9244444 L78.6469755,11.9244444 L83.4300272,0 L78.0657766,0.0222222222 Z" id="Shape" fill="#000000"></path>
                    <path d="M134.510954,5.48444444 C134.287017,5.41042851 134.052932,5.37440508 133.81782,5.37777778 C132.285501,5.33345562 130.885901,6.2707681 130.30049,7.73333333 L130.30049,5.69333333 L125.681035,5.69333333 L125.681035,18.9466667 L130.326322,18.9466667 L130.326322,14.12 C130.326322,11.6577778 131.432752,10.28 133.382997,10.28 C133.766741,10.2725198 134.148703,10.3357311 134.510954,10.4666667 L134.510954,5.48444444 Z M157.586703,14.7066667 C157.586703,12.56 156.174605,11.3911111 153.328883,10.5688889 L152.584087,10.36 C151.529319,10.0666667 151.120327,9.96 151.120327,9.64444444 C151.120327,9.32888889 151.400163,9.08888889 152.093297,9.08888889 C153.450345,9.14730589 154.776143,9.52749663 155.967956,10.2 L157.405886,6.72888889 C155.762922,5.84513411 153.941481,5.37314042 152.088992,5.35111111 C148.778311,5.35111111 146.522398,7.07111111 146.522398,9.85333333 C146.522398,12.2133333 147.981853,13.3511111 150.883542,14.04 L151.550845,14.2 C152.52812,14.44 152.962943,14.5733333 152.962943,14.9422222 C152.962943,15.3866667 152.532425,15.5244444 151.860817,15.5244444 C150.346116,15.4741491 148.867045,15.0374509 147.55564,14.2533333 L145.911063,17.6977778 C147.686591,18.7932991 149.72378,19.3537124 151.791935,19.3155556 C155.180109,19.3155556 157.565177,17.6444444 157.565177,14.7066667 L157.586703,14.7066667 Z M99.466812,23.8755556 L99.466812,17.5422222 C100.358,18.7173685 101.741926,19.3788009 103.186485,19.32 C106.677984,19.32 109.213733,16.2088889 109.213733,12.3244444 C109.213733,8.44 106.69951,5.32888889 103.186485,5.32888889 C101.733545,5.28164108 100.348025,5.96204577 99.466812,7.15555556 L99.466812,5.69777778 L94.7913896,5.69777778 L94.7913896,23.88 L99.466812,23.8755556 Z M99.3376567,12.32 C99.3271861,11.213905 99.9645436,10.210698 100.951431,9.77990287 C101.938319,9.34910772 103.079494,9.57595163 103.84086,10.3542665 C104.602227,11.1325813 104.833158,12.3083876 104.425573,13.3313811 C104.017988,14.3543747 103.052522,15.0221694 101.981035,15.0222222 C101.279555,15.0391913 100.60157,14.760828 100.102982,14.251141 C99.6043938,13.7414539 99.3281085,13.0443046 99.3376567,12.32 L99.3376567,12.32 Z M117.380654,5.32444444 C113.351008,5.32444444 110.3503,8.34666667 110.3503,12.32 C110.3503,16.2933333 113.363924,19.3155556 117.380654,19.3155556 C121.397384,19.3155556 124.389482,16.2933333 124.389482,12.32 C124.389482,8.34666667 121.375858,5.32444444 117.380654,5.32444444 Z M119.925028,12.32 C119.926756,13.3827901 119.307948,14.3419313 118.357325,14.7498901 C117.406702,15.1578489 116.311622,14.9342208 115.583048,14.1833503 C114.854473,13.4324797 114.635998,12.3023557 115.029563,11.3202919 C115.423128,10.338228 116.351165,9.69774364 117.380654,9.69774364 C118.055765,9.6942178 118.704284,9.9692005 119.182069,10.4616073 C119.659855,10.954014 119.927319,11.6230453 119.925028,12.32 L119.925028,12.32 Z M137.378202,1.58666667 L137.378202,5.69333333 L135.656131,5.69333333 L135.656131,9.61333333 L137.378202,9.61333333 L137.378202,14.3288889 C137.378202,17.4844444 139.17346,19.3111111 142.113896,19.3111111 C143.108761,19.3245868 144.098636,19.1637885 145.041417,18.8355556 L145.041417,14.7555556 C144.601078,14.9003846 144.142996,14.9797003 143.680981,14.9911111 C142.600381,14.9911111 142.036403,14.4888889 142.036403,13.2133333 L142.036403,9.65777778 L145.050027,9.65777778 L145.050027,5.76 L142.036403,5.76 L142.036403,1.65333333 L137.378202,1.58666667 Z M93.5342779,14.7066667 C93.5342779,12.56 92.1221798,11.3911111 89.2764578,10.5688889 L88.5316621,10.36 C87.4768937,10.0666667 87.0679019,9.96 87.0679019,9.64444444 C87.0679019,9.32888889 87.3477384,9.08888889 88.0408719,9.08888889 C89.3979195,9.14730589 90.7237182,9.52749663 91.9155313,10.2 L93.3534605,6.72888889 C91.7104967,5.84513411 89.8890562,5.37314042 88.0365668,5.35111111 C84.7258856,5.35111111 82.4699728,7.07111111 82.4699728,9.85333333 C82.4699728,12.2133333 83.9294278,13.3511111 86.8311172,14.04 L87.4984196,14.2 C88.4756948,14.44 88.9105177,14.5733333 88.9105177,14.9422222 C88.9105177,15.3866667 88.48,15.5244444 87.8083924,15.5244444 C86.2936909,15.4741491 84.81462,15.0374509 83.5032153,14.2533333 L81.8586376,17.6977778 C83.6341658,18.7932991 85.6713546,19.3537124 87.7395095,19.3155556 C91.1276839,19.3155556 93.512752,17.6444444 93.512752,14.7066667 L93.5342779,14.7066667 Z" id="Shape" fill="#999999"></path>
                </g>
            </g>
        </g>
    </g>
</svg></div>
</div>
<div class='copyright-notice'>Certain data provided by STATS, LLC</div>
<div class='copyright-notice'>© 2021 Verizon Media. All rights reserved.</div>
</footer>
<script src="https://cdn.rivals.com/production/assets/basicFooter-f52cf31faa2fb51e14b7d11944f0f0d0be3da6cd4353a61c24a499b6101be6e7.js"></script>

</body>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PCEtLSBCZWdpbiBjb21TY29yZSBUYWcgLS0+Cgo8c2NyaXB0PgogIHZhciBf
Y29tc2NvcmUgPSBfY29tc2NvcmUgfHwgW107CiAgX2NvbXNjb3JlLnB1c2go
ewogICAgYzE6ICIyIiwKICAgIGMyOiAiNzI0MTQ2OSIsCiAgICBjNTogIjIw
MjI3MzMxNjQiLAogICAgYzc6ICJodHRwczovL3V0YWgucml2YWxzLmNvbS9u
ZXdzL2luc2lkZS10aGUtbnVtYmVycy1ieXUtMSIKICB9KTsKICAoZnVuY3Rp
b24oKSB7CiAgICB2YXIgcyA9IGRvY3VtZW50LmNyZWF0ZUVsZW1lbnQoInNj
cmlwdCIpLCBlbCA9IGRvY3VtZW50LmdldEVsZW1lbnRzQnlUYWdOYW1lKCJz
Y3JpcHQiKVswXTsgcy5hc3luYyA9IHRydWU7CiAgICAvLyBsb2FkaW5nIHRo
ZSBldmVyZ3JlZW4gdmVyc2lvbiBvZiBjcy5qcyBzbyB3ZSBhbHdheXMgaGF2
ZSB0aGUgbGFzdCB2ZXJzaW9uCiAgICBzLnNyYyA9ICJodHRwczovL3MueWlt
Zy5jb20vY3gvdnptL2NzLmpzIjsKICAgIGVsLnBhcmVudE5vZGUuaW5zZXJ0
QmVmb3JlKHMsIGVsKTsKICB9KSgpOwo8L3NjcmlwdD4KCjxub3NjcmlwdD4K
ICA8aW1nIHNyYz0iaHR0cHM6Ly9zYi5zY29yZWNhcmRyZXNlYXJjaC5jb20v
cD9jMT0yJmMyPTcyNDE0NjkmYzc9aHR0cHMlM0ElMkYlMkZ1dGFoLnJpdmFs
cy5jb20lMkZuZXdzJTJGaW5zaWRlLXRoZS1udW1iZXJzLWJ5dS0xJmM1PTIw
MjI3MzMxNjQmY3Y9Mi4wJmNqPTEmY3NfdWNmcj0wIiAvPgo8L25vc2NyaXB0
Pgo8IS0tIEVuZCBjb21TY29yZSBUYWcgLS0+CgoK

</div>
</div>
</html>
